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Einleitung

Willkommen im Kreis der Keysight VEE-Nutzer!Keysight Visual 
Engineering Environment (VEE) ist eine leistungsfähige visuelle 
Sprachumgebung, mit der Sie Ihre Programme erheblich schneller 
entwickeln können. Damit Sie möglichst schnell mit Keysight VEE starten 
können, wird in dieser Anleitung gezeigt, wie die neue Software 
installiert und verwendet wird. Außerdem beinhaltet diese Anleitung 
zwei Übungseinheiten, in denen erläutert wird, wie über die 
USB-Schnittstelle auf ein Instrument  
zugegriffen und wie eine Wellenform von einer virtuellen Quelle generiert 
und angezeigt werden kann.

Installieren von Keysight IO Libraries

Die Keysight IO Libraries Suite erhalten Sie beim Kauf von Keysight VEE. 
Mit dieser Software können Sie über serielle, USB-, GPIB- oder LAN- 
Schnittstellen auf Instrumente zugreifen. 

Die Keysight IO Libraries Suite 16.3.16603.3 muss installiert sein, bevor 
Keysight VEE installiert wird, wenn Sie über Keysight VEE auf ein 
Instrument zugreifen müssen. Wenn Sie keine Instrumente verwenden, 
können Sie sich jedoch gegen die Installation der Keysight IO Libraries 
Suite entscheiden. 

Führen Sie folgende einfache Installationsschritte aus:

1 Legen Sie die Keysight IO Libraries Suite-CD in das 
CD-ROM-Laufwerk ein. 

2 Der InstallShield® Wizard führt Sie durch die Installationsvorgänge. 
Klicken Sie auf Next, um die Standardeinstellungen zu übernehmen 
und die Installation abzuschließen.
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3 Das Fenster Keysight Connection Expert Welcome Screen wird 
angezeigt. Mit dieser Anwendung werden die Instrumente konfiguriert, 
die an den PC angeschlossen sind. Sie können dieses Fenster 
schließen, bevor Sie den nächsten Schritt ausführen.
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Installieren von Keysight VEE Pro

1 Legen Sie die Keysight VEE-Installations-CD ein, und klicken Sie auf 
Install Keysight VEE Pro 9.32 bzw. Der InstallShield® Wizard führt Sie 
durch die Installationsvorgänge. 

2 Der InstallShield® Wizard prüft nun, ob Keysight IO Libraries Suite 
16.3.16603.3 installiert ist. Ist dies nicht der Fall, wird das folgende 
Meldungsfenster angezeigt.

Beachten Sie, dass Keysight IO Libraries Suite 16.3.16603.3 eine 
Voraussetzung für den Zugriff auf Instrumente über Keysight VEE ist. 
Darum installieren Sie bitte nach Abschluss dieser Installation 
Keysight IO Libraries Suite 16.3.16603.3 oder höher.

3 Klicken Sie auf OK. Der InstallShield® Wizard prüft nun, ob Microsoft 
.NET Framework 3.5 SP1 installiert ist.

4 Falls Microsoft .NET Framework 3.5 SP1 nicht installiert ist, werden 
Sie in einem Dialogfenster gefragt, ob Sie es installieren möchten. 
Klicken Sie auf Yes, um Microsoft .NET Framework 3.5 SP1 sofort zu 
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installieren. Nach der Installation wird die Keysight VEE-Installation 
automatisch fortgesetzt. Wenn Sie auf No klicken, wird die Keysight 
VEE-Installation abgebrochen.

Wenn Microsoft .NET Framework 3.5 SP1 installiert ist, führt der 
InstallShield® Wizard Sie direkt zum nächsten Schritt, der Installation 
Ihrer Keysight VEE-Auswahl in Schritt 1.

5 Klicken Sie auf Next, wenn das folgende Dialogfenster angezeigt wird.

6 Akzeptieren Sie den Lizenzvertrag, wenn das License Agreement- 
Dialogfenster angezeigt wird, und klicken Sie auf Next.
Keysight VEE Pro 9.32 – Kurzanleitung 5



 
 

GM_VEE90_QSG.book  Page 6  Monday, February 9, 2015  12:35 PM
7 Geben Sie Ihren Namen, Unternehmensnamen und Produktschlüssel 
ein, wenn das Customer Information-Dialogfenster angezeigt wird, und 
klicken Sie auf Next. Den Produktschlüssel finden Sie im Keysight VEE 
Pro Product Key Certificate. 
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8 Klicken Sie auf Next, um die Standardeinstellungen zu akzeptieren, 
wenn das folgende Dialogfenster angezeigt wird. 

9 Wählen Sie Typical Setup, wenn das Setup Type-Dialogfenster angezeigt 
wird, und klicken Sie auf Next, um die Installation abzuschließen.
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Starten von Keysight VEE Pro

Wechseln Sie zu All Programs (Alle Programme) > Keysight VEE Pro 9.3 > VEE  
Pro 9.3, um Keysight VEE Pro zu starten.

Über die Begrüßungsseite von Keysight VEE Pro können Sie auf die 
Demos, die MATLAB-Beispiele sowie Beispielprogramme zugreifen. 
Nachdem Sie sich die Begrüßungsseite angesehen haben, können Sie 
diese schließen. 

Beispielprogramme können Sie auch über die Menüleiste öffnen. Wenn 
Sie ein Beispielprogramm öffnen möchten, wählen Sie File > Open  
Example ... oder Help > Open Example ... aus.

Ausgabefenster 
(Output)

Arbeitsbereich

Program 
Explorer

Eigenschaften- 
fenster(Properties)

Toolbar

Statusleiste

Menüleiste

Begrüßungs-
seite
8 Keysight VEE Pro 9.32 – Kurzanleitung



 

GM_VEE90_QSG.book  Page 9  Monday, February 9, 2015  12:35 PM
Zugreifen auf ein Instrument - Übungseinheit

In dieser Übungseinheit wird über die USB-Schnittstelle eine Verbindung 
zu einem Instrument hergestellt. Führen Sie die weiteren Schritte erst 
aus, nachdem Sie sich vergewissert haben, dass die Keysight IO Libraries 
Suite 16.3.16603.3 installiert ist. 

Wenn Sie kein USB-Instrument haben, können Sie zu Schritt 3 springen. 
Die Übungseinheit ist ab diesem Schritt für ein GPIB-Instrument gleich. 

1 Stellen Sie über einen USB-Anschluss des PCs eine Verbindung zum 
Instrument her. Schalten Sie dann das Instrument ein. Möglicherweise 
wird der Assistent für das Suchen neuer Hardware (Found New 
Hardware Wizard) angezeigt. Folgen Sie dem Assistenten, indem Sie 
auf Next klicken.

2 Starten Sie Keysight VEE Pro, sofern Sie dies nicht bereits getan haben. 
Klicken Sie in der Symbolleiste auf das Symbol Instrument Manager  .

3 Das Toolfenster Instrument Manager wird angezeigt. Klicken Sie auf 
 
die Schaltfläche Find Instruments         , um automatisch alle 
Instrumente zu ermitteln, die mit Ihrem PC verbunden sind.

4 Klicken Sie auf OK, wenn das Popup-Dialogfenster „Identify 
Instrument“ angezeigt wird. Dadurch wird das Instrument an der 
USB-Schnittstelle automatisch erkannt (identifiziert). In diesem 
Beispiel ist das Keysight 34450A Multimeter mit 5½ Ziffern vorhanden.
Keysight VEE Pro 9.32 – Kurzanleitung 9
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5 Klicken Sie mit der rechten Maustaste im Bereich „Instrument List“ 
auf den Eintrag für das neue Instrument (newInstrument). Wählen Sie 
anschließend Create Direct I/O Object, um das Direct I/O-Objekt für das 
ausgewählte neue Instrument (newinstrument) auf dem 
Arbeitsbereich zu platzieren.Über dieses Objekt können Sie Befehle an 
das/vom Instrument senden/empfangen.

6 Doppelklicken Sie auf die blaue Transaktionsleiste des Direct 
I/O-Objekts, damit Sie ihm eine Transaktion hinzufügen können.

7 Geben Sie im Dialogfenster I/O Transaction die Zeichenfolge "*IDN?"  
ein. Geben Sie auch die Anführungszeichen ein (siehe Abbildung). 
Während der Eingabe wird möglicherweise eine Liste verfügbarer SCPI- 
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Befehle angezeigt. Sie können den gewünschten Befehl wählen, anstatt 
den ganzen Befehl einzugeben. Klicken Sie zum Fortsetzen auf OK.

*IDN? ist einer der Standardbefehle für programmierbare Instrumente 
(SCPI - Standard Commands for Programmable Instruments). Dieser Befehl 
fragt die Identifikationsszeichenfolge eines Instruments ab.

8 Nach dem Senden der Abfrage "*IDN?" an das Instrument muss dessen 
Antwort gelesen werden. Doppelklicken Sie auf das Textfeld des 
newInstrument-Objekts, damit Sie eine neue Transaktion hinzufügen 
können. Wählen Sie jezt die Transaktion READ zur Ausgabe eines Textes im 
STRING FORMAT (Zeichenfolgenformat) an einem Ausgabeterminal x. Der 
Ausgang x wird automatisch erstellt, sobald Sie auf OK geklickt haben.
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9 Wählen Sie Display > AlphaNumeric aus und ordnen Sie ein 
AlphaNumeric-Objekt im Arbeitsbereich rechts neben dem Direct 
I/O-Objekt an.

10 Das Direct I/O -Objekt soll nun mit dem AlphaNumeric-Objekt 
verbunden werden. Platzieren Sie den Cursor neben dem Ausgang des 
Direct I/O-Objekts. Es wird ein quadratisches Symbol angezeigt. 
Klicken Sie mit der linken Maustaste und ziehen Sie eine Linie zum 
Eingabeanschluss (input terminal, Eingang) des 
AlphaNumeric-Objekts. Klicken Sie erneut mit der linken Maustaste, 
um die Verbindung abzuschließen.

11 Führen Sie das Programm aus, indem Sie in der Symbolleiste auf das 

Symbol Run  klicken.

12 Das AlphaNumeric-Objekt zeigt die Identifikationszeichenfolge an, die 
das Instrument ausgegeben hat (siehe folgende Abbildung).

13 Zum Speichern des VEE-Codes wählen Sie File > Save As aus. Geben Sie 
der Datei den Namen Uebungseinheit 1.vee.
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Virtuelle Quelle (Virtual Source) - Übungseinheit

In dieser Übungseinheit generieren Sie eine Wellenform aus einer 
virtuellen Quelle und zeigen diese Wellenform an. Es ist kein Instrument 
erforderlich.

1 Wenn im Arbeitsbereich von Keysight VEE Pro ein Programm 
vorhanden ist, wählen Sie File > New aus. Wählen Sie dann Device > 
Virtual Source > Function Generator aus, und ordnen Sie im Arbeitsbereich 
ein Function Generator-Objekt an.

2 Der Funktionsgenerator erzeugt standardmäßig eine virtuelle 
Cosine-Wellenform (Kosinus) mit der Frequenz (Frequency) 200 Hz 
und der Amplitude 1.  
Keysight VEE Pro 9.32 – Kurzanleitung 13
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3 Wählen Sie Display > XY Trace aus, und legen Sie ein XY Trace-Objekt 
rechts neben dem Function Generator-Objekt ab. 

4 Verbinden Sie den Ausgang des Function Generator-Objekts mit dem 
Eingang des XY Trace-Objekts. Platzieren Sie den Mauscursor neben 
dem Ausgang des Function Generator-Objekts. Es wird ein 
quadratisches Symbol angezeigt. Klicken Sie mit der linken Maustaste 
und ziehen Sie eine Linie zum Eingang des XY Trace-Objekts. Klicken 
Sie erneut mit der linken Maustaste, um die Verbindung abzuschließen.
14 Keysight VEE Pro 9.32 – Kurzanleitung
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5 Klicken Sie in der Symbolleiste auf das Symbol Run . Danach  
wird die Kosinuswellenform im XY Trace-Objekt angezeigt. 

6 Wählen Sie Display > Spectrum (Freq) > Magnitude Spectrum aus und legen 
Sie im Arbeitsbereich ein Magnitude Spectrum-Objekt unter dem XY 
Trace-Objekt ab.
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7 Ziehen Sie gemäß der in Schritt 4 beschriebenen Methode des 
Linksklickens und Ablegens eine zweite Linie vom Ausgang des 
Function Generator-Objekts zum Eingang des Magnitude 
Spectrum-Objekts.

8 Klicken Sie auf das Symbol Run , und sehen Sie sich die Anzeige 
des Magnitude Spectrum-Objekts an. Da die Wellenform einer 200-Hz- 
Kosinuswelle entspricht, zeigt das Magnitude Spectrum-Objekt eine 
vertikale Linie bei der Frequenz 200 Hz an.
16 Keysight VEE Pro 9.32 – Kurzanleitung
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9 Ändern Sie die Funktion im Generator für virtuelle Funktionen in eine 
rechteckige (Square) Wellenform. 

10 Klicken Sie auf das Symbol Run  und beobachten Sie den 
Unterschied. Keysight VEE bietet Ihnen die Möglichkeit, eine 
Signalquelle gleichzeitig in mehreren Grafikdarstellungen zu 
analysieren. 
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11 Zum Speichern des VEE-Codes wählen Sie File > Save As aus. Geben Sie 
der Datei den Namen Uebungseinheit 2.vee.
18 Keysight VEE Pro 9.32 – Kurzanleitung



 

GM_VEE90_QSG.book  Page 19  Monday, February 9, 2015  12:35 PM
Keysight VEE 9.32 – neue Eigenschaften

Windows 8 Unterstützung

Keysight VEE 9.32 unterstützt Windows 8 (Professional und Enterprise 
mit Unterstützung von 32 und 64 Bit). Hinweis: Die 64-Bit-Unterstützung 
verfügt über eine 32-Bit-Anwendung, die auf einem WOW64-Emulator 
(Windows-on-Windows 64-bit) ausgeführt wird.

Unterstützung für Microsoft Office Excel 2013

Das in Keysight VEE 9.32 (und höheren Versionen) integrierte 
Excel-Menü unterstützt Microsoft Office Excel 2013. Neue Funktionen 
von Microsoft Office Excel 2013 werden jedoch nicht unterstützt.

HINWEIS Keysight bietet auch die Versionen Keysight VEE Student und Keysight Education für 
Benutzer im Ausbildungsbereich an.
Keysight VEE Pro 9.32 – Kurzanleitung 19
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Keysight-Konnektivitätsprodukte

Keysight bietet eine umfassende Palette von sehr leistungsfähigen und 
zuverlässigen Produkten an, über die PCs mit Instrumenten verbunden 
werden können. Hierzu zählen LAN/GPIB/USB-Gateway, GPIB-Kabel und 
PCI GPIB-, PCIe GPIB- und USB/GPIB-Schnittstellen. Weitere 
Informationen zu den Konnektivitätsprodukten von Keysight finden Sie 
hier: www.keysight.com/find/gpib.

E5810B LAN/GPIB/USB-Gateway GPIB-Kabel 10833X

PCI-GPIB-Schnittstelle 82350B

USB-/GPIB-Schnittstelle 82357B

PCIe-GPIB-Schnittstelle 82351A
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Keysight-Unterstützung, -Dienstleistungen und -Aktualisierung

Mit Keysight VEE Pro haben Sie Zugriff auf die weltweiten 
Keysight-Ressourcen für die Erstunterstützung, für Schulungen und für 
Aktualisierungen. Mit dem Kauf irgendeines Keysight VEE-Produkts 
erwerben Sie das Recht, kostenfreie technische Unterstützung zu 
erhalten. Eine Registrierung ist nicht erforderlich. 

Keysight bietet weitere Beratungsdienstleistungen an. In den USA, in 
Europa und im Nahen Osten gibt es momentan mehr als 30 Unternehmen, 
von denen Sie beim Entwickeln von Keysight VEE-Lösungen unterstützt 
werden können.

Melden Sie sich für die elektronische Keysight VEE-Benutzergruppe unter 
http://www.keysight.com/find/veeforum. Hier erhalten Sie von Experten 
auf der ganzen Welt Hilfe zum Arbeiten mit Keysight VEE.

Tragen Sie sich für E-Learning-Kurse zu Keysight VEE (LearnVEE) ein 
unter http://www.keysight.com/find/learnvee.

Interaktive Hilfe erhalten Sie auch mit den multimedialen Keysight 
VEE-Demos unter http://www.keysight.com/find/veedemos.
Keysight VEE Pro 9.32 – Kurzanleitung 21
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Anhang

Keysight VEE Pro Help steht jetzt auch in anderen Sprachen zur 
Verfügung. Um Online-Hilfedateien in anderen Sprachen zu nutzen, 
führen Sie bitte folgende Schritte aus: 

1 Laden Sie die lokalisierte Online-Hilfe unter  
www.keysight.com/find/vee herunter.

2 Speichern Sie heruntergeladene Dateien im Installationsverzeichnis von 
Keysight VEE. Im Allgemeinen handelt es sich hier bei um C:\
Programme\Keysight\VEE Pro 9.3 (32-Bit-Betriebssystem) oder C:\
Programme (x86)\Keysight\VEE Pro 9.3 (64-Bit-Betriebssystem). 
Ändern Sie die Namen der heruntergeladenen Online-Hilfedateien bitte 
nicht.

3 Öffnen Sie Keysight VEE.

4 Öffnen Sie den Ordner mit den Standardvoreinstellungen (File > Default 
Preferences). Wählen Sie die gewünschte Hilfedateisprache auf der 
Registerkarte „Help“.

5 Klicken Sie auf „OK“, um das Dialogfenster „Default Preferences“ zu 
schließen.
22 Keysight VEE Pro 9.32 – Kurzanleitung
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